MediaTekDocuments.dal Namespace

[Missing <summary> documentation for "N:MediaTekDocuments.dal"]

Classes
 | Class | Description
Public class | Access | Classe d'accès aux données


Access Class

Classe d'accès aux données
Inheritance Hierarchy
SystemObject
MediaTekDocuments.dalAccess

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Access

The Access type exposes the following members.

Methods
 | Name | Description
Public method | CreerEntite | Créer une entite dans la BDD, return true si l'opération, c'est correctement déroulé
Public method | CreerExemplaire | ecriture d'un exemplaire en base de données
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAbonnements | Retourne les abonnements d'une revue
Public method | GetAllDvd | Retourne toutes les dvd à partir de la BDD
Public method | GetAllEtats | Retourne tous les etats à partir de la BDD
Public method | GetAllGenres | Retourne tous les genres à partir de la BDD
Public method | GetAllLivres | Retourne toutes les livres à partir de la BDD
Public method | GetAllPublics | Retourne toutes les catégories de public à partir de la BDD
Public method | GetAllRayons | Retourne tous les rayons à partir de la BDD
Public method | GetAllRevues | Retourne toutes les revues à partir de la BDD
Public method | GetAllSuivis | Retourne tous les suivis à partir de la BDD
Public method | GetCommandesLivres | Retourne les commandes d'un livre
Public method | GetExemplairesRevue | Retourne les exemplaires d'une revue
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetInstance | Création et retour de l'instance unique de la classe
Public method | GetLogin |
Public method | GetMaxIndex | Retourne l'index max en string de certaines tables
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SupprimerEntite | Supprime une entité dans la BDD, return true si l'opération, c'est correctement déroulé
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateEntite | Modifie une entite dans la BDD, return true si l'opération, c'est correctement déroulé
Top
See Also

Reference

MediaTekDocuments.dal Namespace


Access Methods

The Access type exposes the following members.

Methods
 | Name | Description
Public method | CreerEntite | Créer une entite dans la BDD, return true si l'opération, c'est correctement déroulé
Public method | CreerExemplaire | ecriture d'un exemplaire en base de données
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAbonnements | Retourne les abonnements d'une revue
Public method | GetAllDvd | Retourne toutes les dvd à partir de la BDD
Public method | GetAllEtats | Retourne tous les etats à partir de la BDD
Public method | GetAllGenres | Retourne tous les genres à partir de la BDD
Public method | GetAllLivres | Retourne toutes les livres à partir de la BDD
Public method | GetAllPublics | Retourne toutes les catégories de public à partir de la BDD
Public method | GetAllRayons | Retourne tous les rayons à partir de la BDD
Public method | GetAllRevues | Retourne toutes les revues à partir de la BDD
Public method | GetAllSuivis | Retourne tous les suivis à partir de la BDD
Public method | GetCommandesLivres | Retourne les commandes d'un livre
Public method | GetExemplairesRevue | Retourne les exemplaires d'une revue
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetInstance | Création et retour de l'instance unique de la classe
Public method | GetLogin |
Public method | GetMaxIndex | Retourne l'index max en string de certaines tables
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SupprimerEntite | Supprime une entité dans la BDD, return true si l'opération, c'est correctement déroulé
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateEntite | Modifie une entite dans la BDD, return true si l'opération, c'est correctement déroulé
Top
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.CreerEntite Method

A Sandcastle Documented Class Library

AccessCreerEntite Method

Créer une entite dans la BDD, return true si l'opération, c'est correctement déroulé

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool CreerEntite(
    string type,
    string jsonEntite
)

Parameters

type String

[Missing <param name="type"/> documentation for "M:MediaTekDocuments.dal.Access.CreerEntite(System.String,System.String)"]

jsonEntite String

[Missing <param name="jsonEntite"/> documentation for "M:MediaTekDocuments.dal.Access.CreerEntite(System.String,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.CreerEntite(System.String,System.String)"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.CreerExemplaire Method

A Sandcastle Documented Class Library

AccessCreerExemplaire Method

ecriture d'un exemplaire en base de données

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool CreerExemplaire(
    Exemplaire exemplaire
)

Parameters

exemplaire Exemplaire
exemplaire à insérer

Return Value

Boolean
true si l'insertion a pu se faire (retour != null)
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAbonnements Method

A Sandcastle Documented Class Library

AccessGetAbonnements Method

Retourne les abonnements d'une revue

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Abonnement> GetAbonnements(
    string idRevue
)

Parameters

idRevue String

[Missing <param name="idRevue"/> documentation for "M:MediaTekDocuments.dal.Access.GetAbonnements(System.String)"]

Return Value

List Abonnement

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.GetAbonnements(System.String)"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAllDvd Method

A Sandcastle Documented Class Library

AccessGetAllDvd Method

Retourne toutes les dvd à partir de la BDD

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Dvd> GetAllDvd()

Return Value

List Dvd
Liste d'objets Dvd
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAllEtats Method

A Sandcastle Documented Class Library

AccessGetAllEtats Method

Retourne tous les etats à partir de la BDD

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Etat> GetAllEtats()

Return Value

List Etat

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.GetAllEtats"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAllGenres Method

A Sandcastle Documented Class Library

AccessGetAllGenres Method

Retourne tous les genres à partir de la BDD

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Categorie> GetAllGenres()

Return Value

List Categorie
Liste d'objets Genre
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAllLivres Method

A Sandcastle Documented Class Library

AccessGetAllLivres Method

Retourne toutes les livres à partir de la BDD

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Livre> GetAllLivres()

Return Value

List Livre
Liste d'objets Livre
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAllPublics Method

A Sandcastle Documented Class Library

AccessGetAllPublics Method

Retourne toutes les catégories de public à partir de la BDD

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Categorie> GetAllPublics()

Return Value

List Categorie
Liste d'objets Public
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAllRayons Method

A Sandcastle Documented Class Library

AccessGetAllRayons Method

Retourne tous les rayons à partir de la BDD

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Categorie> GetAllRayons()

Return Value

List Categorie
Liste d'objets Rayon
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAllRevues Method

A Sandcastle Documented Class Library

AccessGetAllRevues Method

Retourne toutes les revues à partir de la BDD

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Revue> GetAllRevues()

Return Value

List Revue
Liste d'objets Revue
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetAllSuivis Method

A Sandcastle Documented Class Library

AccessGetAllSuivis Method

Retourne tous les suivis à partir de la BDD

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Suivi> GetAllSuivis()

Return Value

List Suivi

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.GetAllSuivis"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetCommandesLivres Method

A Sandcastle Documented Class Library

AccessGetCommandesLivres Method

Retourne les commandes d'un livre

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<CommandeDocument> GetCommandesLivres(
    string idLivre
)

Parameters

idLivre String

[Missing <param name="idLivre"/> documentation for "M:MediaTekDocuments.dal.Access.GetCommandesLivres(System.String)"]

Return Value

List CommandeDocument

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.GetCommandesLivres(System.String)"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetExemplairesRevue Method

A Sandcastle Documented Class Library

AccessGetExemplairesRevue Method

Retourne les exemplaires d'une revue

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<Exemplaire> GetExemplairesRevue(
    string idDocument
)

Parameters

idDocument String
id de la revue concernée

Return Value

List Exemplaire
Liste d'objets Exemplaire
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetInstance Method

A Sandcastle Documented Class Library

AccessGetInstance Method

Création et retour de l'instance unique de la classe

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static Access GetInstance()

Return Value

Access
instance unique de la classe
See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetLogin Method

A Sandcastle Documented Class Library

AccessGetLogin Method

[Missing <summary> documentation for "M:MediaTekDocuments.dal.Access.GetLogin(System.String,System.String)"]

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Utilisateur GetLogin(
    string mail,
    string hash
)

Parameters

mail String

[Missing <param name="mail"/> documentation for "M:MediaTekDocuments.dal.Access.GetLogin(System.String,System.String)"]

hash String

[Missing <param name="hash"/> documentation for "M:MediaTekDocuments.dal.Access.GetLogin(System.String,System.String)"]

Return Value

Utilisateur

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.GetLogin(System.String,System.String)"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.GetMaxIndex Method

A Sandcastle Documented Class Library

AccessGetMaxIndex Method

Retourne l'index max en string de certaines tables

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string GetMaxIndex(
    string maxIndex
)

Parameters

maxIndex String

[Missing <param name="maxIndex"/> documentation for "M:MediaTekDocuments.dal.Access.GetMaxIndex(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.GetMaxIndex(System.String)"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.SupprimerEntite Method

A Sandcastle Documented Class Library

AccessSupprimerEntite Method

Supprime une entité dans la BDD, return true si l'opération, c'est correctement déroulé

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool SupprimerEntite(
    string type,
    string jsonEntite
)

Parameters

type String

[Missing <param name="type"/> documentation for "M:MediaTekDocuments.dal.Access.SupprimerEntite(System.String,System.String)"]

jsonEntite String

[Missing <param name="jsonEntite"/> documentation for "M:MediaTekDocuments.dal.Access.SupprimerEntite(System.String,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.SupprimerEntite(System.String,System.String)"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


Access.UpdateEntite Method

A Sandcastle Documented Class Library

AccessUpdateEntite Method

Modifie une entite dans la BDD, return true si l'opération, c'est correctement déroulé

Namespace: MediaTekDocuments.dal
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool UpdateEntite(
    string type,
    string id,
    string jsonEntite
)

Parameters

type String

[Missing <param name="type"/> documentation for "M:MediaTekDocuments.dal.Access.UpdateEntite(System.String,System.String,System.String)"]

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.dal.Access.UpdateEntite(System.String,System.String,System.String)"]

jsonEntite String

[Missing <param name="jsonEntite"/> documentation for "M:MediaTekDocuments.dal.Access.UpdateEntite(System.String,System.String,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:MediaTekDocuments.dal.Access.UpdateEntite(System.String,System.String,System.String)"]

See Also

Reference

Access Class
MediaTekDocuments.dal Namespace


MediaTekDocuments.model Namespace

[Missing <summary> documentation for "N:MediaTekDocuments.model"]

Classes
 | Class | Description
Public class | Abonnement |
Public class | Categorie | Classe métier Categorie (réunit les informations des classes Public, Genre et Rayon)
Public class | Commande |
Public class | CommandeDocument |
Public class | Document | Classe métier Document (réunit les infomations communes à tous les documents : Livre, Revue, Dvd)
Public class | Dvd | Classe métier Dvd hérite de LivreDvd : contient des propriétés spécifiques aux dvd
Public class | Etat | Classe métier Etat (état d'usure d'un document)
Public class | Exemplaire | Classe métier Exemplaire (exemplaire d'une revue)
Public class | Genre | Classe métier Genre : hérite de Categorie
Public class | Livre | Classe métier Livre hérite de LivreDvd : contient des propriétés spécifiques aux livres
Public class | LivreDvd | Classe métier LivreDvd hérite de Document
Public class | Public | Classe métier Public (public concerné par le document) hérite de Categorie
Public class | Rayon | Classe métier Rayon (rayon de classement du document) hérite de Categorie
Public class | Revue | Classe métier Revue hérite de Document : contient des propriétés spécifiques aux revues
Public class | Service | Classe métier liée à la table Service
Public class | Suivi |
Public class | Utilisateur |


Abonnement Class

[Missing <summary> documentation for "T:MediaTekDocuments.model.Abonnement"]

Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelCommande
MediaTekDocuments.modelAbonnement

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Abonnement : Commande

The Abonnement type exposes the following members.

Constructors
 | Name | Description
Public method | Abonnement | Initializes a new instance of the Abonnement class
Top
Properties
 | Name | Description
Public property | DateCommande | (Inherited from Commande)
Public property | DateFinAbonnement |
Public property | Id | (Inherited from Commande)
Public property | IdRevue |
Public property | Montant | (Inherited from Commande)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MediaTekDocuments.model Namespace


Abonnement Constructor

Initializes a new instance of the Abonnement class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Abonnement(
    string id,
    DateTime dateCommande,
    double montant,
    DateTime dateFinAbonnement,
    string idRevue
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Abonnement.#ctor(System.String,System.DateTime,System.Double,System.DateTime,System.String)"]

dateCommande DateTime

[Missing <param name="dateCommande"/> documentation for "M:MediaTekDocuments.model.Abonnement.#ctor(System.String,System.DateTime,System.Double,System.DateTime,System.String)"]

montant Double

[Missing <param name="montant"/> documentation for "M:MediaTekDocuments.model.Abonnement.#ctor(System.String,System.DateTime,System.Double,System.DateTime,System.String)"]

dateFinAbonnement DateTime

[Missing <param name="dateFinAbonnement"/> documentation for "M:MediaTekDocuments.model.Abonnement.#ctor(System.String,System.DateTime,System.Double,System.DateTime,System.String)"]

idRevue String

[Missing <param name="idRevue"/> documentation for "M:MediaTekDocuments.model.Abonnement.#ctor(System.String,System.DateTime,System.Double,System.DateTime,System.String)"]

See Also

Reference

Abonnement Class


Abonnement Properties

The Abonnement type exposes the following members.

Properties
 | Name | Description
Public property | DateCommande | (Inherited from Commande)
Public property | DateFinAbonnement |
Public property | Id | (Inherited from Commande)
Public property | IdRevue |
Public property | Montant | (Inherited from Commande)
Top
See Also

Reference

Abonnement Class


Abonnement.DateFinAbonnement Property

A Sandcastle Documented Class Library

AbonnementDateFinAbonnement Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Abonnement.DateFinAbonnement"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DateTime DateFinAbonnement { get; }

Property Value

DateTime
See Also

Reference

Abonnement Class


Abonnement.IdRevue Property

A Sandcastle Documented Class Library

AbonnementIdRevue Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Abonnement.IdRevue"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string IdRevue { get; }

Property Value

String
See Also

Reference

Abonnement Class


Abonnement Methods

The Abonnement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Abonnement Class


Categorie Class

Classe métier Categorie (réunit les informations des classes Public, Genre et Rayon)
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelCategorie
MediaTekDocuments.modelGenre
MediaTekDocuments.modelPublic
MediaTekDocuments.modelRayon

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Categorie

The Categorie type exposes the following members.

Constructors
 | Name | Description
Public method | Categorie | Initializes a new instance of the Categorie class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Libelle |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Overrides ObjectToString)
Top
See Also

Reference


Categorie Constructor

Initializes a new instance of the Categorie class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Categorie(
    string id,
    string libelle
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Categorie.#ctor(System.String,System.String)"]

libelle String

[Missing <param name="libelle"/> documentation for "M:MediaTekDocuments.model.Categorie.#ctor(System.String,System.String)"]

See Also

Reference

Categorie Class


Categorie Properties

The Categorie type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Libelle |
Top
See Also

Reference

Categorie Class


Categorie.Id Property

A Sandcastle Documented Class Library

CategorieId Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Categorie.Id"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Id { get; }

Property Value

String
See Also

Reference

Categorie Class


Categorie.Libelle Property

A Sandcastle Documented Class Library

CategorieLibelle Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Categorie.Libelle"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Libelle { get; }

Property Value

String
See Also

Reference

Categorie Class


Categorie Methods

The Categorie type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Overrides ObjectToString)
Top
See Also

Reference

Categorie Class


Categorie.ToString Method

A Sandcastle Documented Class Library

CategorieToString Method

Récupération du libellé pour l'affichage dans les combos

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
Libelle
See Also

Reference

Categorie Class


Commande Class

[Missing <summary> documentation for "T:MediaTekDocuments.model.Commande"]

Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelCommande
MediaTekDocuments.modelAbonnement
MediaTekDocuments.modelCommandeDocument

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Commande

The Commande type exposes the following members.

Constructors
 | Name | Description
Public method | Commande | Initializes a new instance of the Commande class
Top
Properties
 | Name | Description
Public property | DateCommande |
Public property | Id |
Public property | Montant |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


Commande Constructor

Initializes a new instance of the Commande class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Commande(
    string id,
    DateTime dateCommande,
    double montant
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Commande.#ctor(System.String,System.DateTime,System.Double)"]

dateCommande DateTime

[Missing <param name="dateCommande"/> documentation for "M:MediaTekDocuments.model.Commande.#ctor(System.String,System.DateTime,System.Double)"]

montant Double

[Missing <param name="montant"/> documentation for "M:MediaTekDocuments.model.Commande.#ctor(System.String,System.DateTime,System.Double)"]

See Also

Reference

Commande Class


Commande Properties

The Commande type exposes the following members.

Properties
 | Name | Description
Public property | DateCommande |
Public property | Id |
Public property | Montant |
Top
See Also

Reference

Commande Class


Commande.DateCommande Property

A Sandcastle Documented Class Library

CommandeDateCommande Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Commande.DateCommande"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DateTime DateCommande { get; set; }

Property Value

DateTime
See Also

Reference

Commande Class


Commande.Id Property

A Sandcastle Documented Class Library

CommandeId Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Commande.Id"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Id { get; }

Property Value

String
See Also

Reference

Commande Class


Commande.Montant Property

A Sandcastle Documented Class Library

CommandeMontant Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Commande.Montant"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public double Montant { get; }

Property Value

Double
See Also

Reference

Commande Class


Commande Methods

The Commande type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Commande Class


CommandeDocument Class

[Missing <summary> documentation for "T:MediaTekDocuments.model.CommandeDocument"]

Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelCommande
MediaTekDocuments.modelCommandeDocument

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class CommandeDocument : Commande

The CommandeDocument type exposes the following members.

Constructors
 | Name | Description
Public method | CommandeDocument | Initializes a new instance of the CommandeDocument class
Top
Properties
 | Name | Description
Public property | DateCommande | (Inherited from Commande)
Public property | Etat |
Public property | Id | (Inherited from Commande)
Public property | IdLivreDvd |
Public property | IdSuivi |
Public property | Montant | (Inherited from Commande)
Public property | NbExemplaire |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


CommandeDocument Constructor

Initializes a new instance of the CommandeDocument class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public CommandeDocument(
    string id,
    DateTime dateCommande,
    float montant,
    int nbExemplaire,
    string idLivreDvd,
    int idSuivi,
    string etat
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.CommandeDocument.#ctor(System.String,System.DateTime,System.Single,System.Int32,System.String,System.Int32,System.String)"]

dateCommande DateTime

[Missing <param name="dateCommande"/> documentation for "M:MediaTekDocuments.model.CommandeDocument.#ctor(System.String,System.DateTime,System.Single,System.Int32,System.String,System.Int32,System.String)"]

montant Single

[Missing <param name="montant"/> documentation for "M:MediaTekDocuments.model.CommandeDocument.#ctor(System.String,System.DateTime,System.Single,System.Int32,System.String,System.Int32,System.String)"]

nbExemplaire Int32

[Missing <param name="nbExemplaire"/> documentation for "M:MediaTekDocuments.model.CommandeDocument.#ctor(System.String,System.DateTime,System.Single,System.Int32,System.String,System.Int32,System.String)"]

idLivreDvd String

[Missing <param name="idLivreDvd"/> documentation for "M:MediaTekDocuments.model.CommandeDocument.#ctor(System.String,System.DateTime,System.Single,System.Int32,System.String,System.Int32,System.String)"]

idSuivi Int32

[Missing <param name="idSuivi"/> documentation for "M:MediaTekDocuments.model.CommandeDocument.#ctor(System.String,System.DateTime,System.Single,System.Int32,System.String,System.Int32,System.String)"]

etat String

[Missing <param name="etat"/> documentation for "M:MediaTekDocuments.model.CommandeDocument.#ctor(System.String,System.DateTime,System.Single,System.Int32,System.String,System.Int32,System.String)"]

See Also

Reference

CommandeDocument Class


CommandeDocument Properties

The CommandeDocument type exposes the following members.

Properties
 | Name | Description
Public property | DateCommande | (Inherited from Commande)
Public property | Etat |
Public property | Id | (Inherited from Commande)
Public property | IdLivreDvd |
Public property | IdSuivi |
Public property | Montant | (Inherited from Commande)
Public property | NbExemplaire |
Top
See Also

Reference

CommandeDocument Class


CommandeDocument.Etat Property

A Sandcastle Documented Class Library

CommandeDocumentEtat Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.CommandeDocument.Etat"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Etat { get; }

Property Value

String
See Also

Reference

CommandeDocument Class


CommandeDocument.IdLivreDvd Property

A Sandcastle Documented Class Library

CommandeDocumentIdLivreDvd Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.CommandeDocument.IdLivreDvd"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string IdLivreDvd { get; }

Property Value

String
See Also

Reference

CommandeDocument Class


CommandeDocument.IdSuivi Property

A Sandcastle Documented Class Library

CommandeDocumentIdSuivi Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.CommandeDocument.IdSuivi"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int IdSuivi { get; }

Property Value

Int32
See Also

Reference

CommandeDocument Class


CommandeDocument.NbExemplaire Property

A Sandcastle Documented Class Library

CommandeDocumentNbExemplaire Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.CommandeDocument.NbExemplaire"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int NbExemplaire { get; }

Property Value

Int32
See Also

Reference

CommandeDocument Class


CommandeDocument Methods

The CommandeDocument type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CommandeDocument Class


Document Class

Classe métier Document (réunit les infomations communes à tous les documents : Livre, Revue, Dvd)
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelDocument
MediaTekDocuments.modelLivreDvd
MediaTekDocuments.modelRevue

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Document

The Document type exposes the following members.

Constructors
 | Name | Description
Public method | Document | Initializes a new instance of the Document class
Top
Properties
 | Name | Description
Public property | Genre |
Public property | Id |
Public property | IdGenre |
Public property | IdPublic |
Public property | IdRayon |
Public property | Image |
Public property | Public |
Public property | Rayon |
Public property | Titre |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


Document Constructor

Initializes a new instance of the Document class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Document(
    string id,
    string titre,
    string image,
    string idGenre,
    string genre,
    string idPublic,
    string lePublic,
    string idRayon,
    string rayon
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

titre String

[Missing <param name="titre"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

image String

[Missing <param name="image"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idGenre String

[Missing <param name="idGenre"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

genre String

[Missing <param name="genre"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idPublic String

[Missing <param name="idPublic"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

lePublic String

[Missing <param name="lePublic"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idRayon String

[Missing <param name="idRayon"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

rayon String

[Missing <param name="rayon"/> documentation for "M:MediaTekDocuments.model.Document.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

See Also

Reference

Document Class


Document Properties

The Document type exposes the following members.

Properties
 | Name | Description
Public property | Genre |
Public property | Id |
Public property | IdGenre |
Public property | IdPublic |
Public property | IdRayon |
Public property | Image |
Public property | Public |
Public property | Rayon |
Public property | Titre |
Top
See Also

Reference

Document Class


Document.Genre Property

A Sandcastle Documented Class Library

DocumentGenre Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.Genre"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Genre { get; }

Property Value

String
See Also

Reference

Document Class


Document.Id Property

A Sandcastle Documented Class Library

DocumentId Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.Id"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Id { get; }

Property Value

String
See Also

Reference

Document Class


Document.IdGenre Property

A Sandcastle Documented Class Library

DocumentIdGenre Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.IdGenre"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string IdGenre { get; }

Property Value

String
See Also

Reference

Document Class


Document.IdPublic Property

A Sandcastle Documented Class Library

DocumentIdPublic Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.IdPublic"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string IdPublic { get; }

Property Value

String
See Also

Reference

Document Class


Document.IdRayon Property

A Sandcastle Documented Class Library

DocumentIdRayon Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.IdRayon"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string IdRayon { get; }

Property Value

String
See Also

Reference

Document Class


Document.Image Property

A Sandcastle Documented Class Library

DocumentImage Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.Image"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Image { get; }

Property Value

String
See Also

Reference

Document Class


Document.Public Property

A Sandcastle Documented Class Library

DocumentPublic Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.Public"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Public { get; }

Property Value

String
See Also

Reference

Document Class


Document.Rayon Property

A Sandcastle Documented Class Library

DocumentRayon Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.Rayon"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Rayon { get; }

Property Value

String
See Also

Reference

Document Class


Document.Titre Property

A Sandcastle Documented Class Library

DocumentTitre Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Document.Titre"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Titre { get; }

Property Value

String
See Also

Reference

Document Class


Document Methods

The Document type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Document Class


Dvd Class

Classe métier Dvd hérite de LivreDvd : contient des propriétés spécifiques aux dvd
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelDocument
MediaTekDocuments.modelLivreDvd
MediaTekDocuments.modelDvd

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Dvd : LivreDvd

The Dvd type exposes the following members.

Constructors
 | Name | Description
Public method | Dvd | Initializes a new instance of the Dvd class
Top
Properties
 | Name | Description
Public property | Duree |
Public property | Genre | (Inherited from Document)
Public property | Id | (Inherited from Document)
Public property | IdGenre | (Inherited from Document)
Public property | IdPublic | (Inherited from Document)
Public property | IdRayon | (Inherited from Document)
Public property | Image | (Inherited from Document)
Public property | Public | (Inherited from Document)
Public property | Rayon | (Inherited from Document)
Public property | Realisateur |
Public property | Synopsis |
Public property | Titre | (Inherited from Document)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


Dvd Constructor

Initializes a new instance of the Dvd class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Dvd(
    string id,
    string titre,
    string image,
    int duree,
    string realisateur,
    string synopsis,
    string idGenre,
    string genre,
    string idPublic,
    string lePublic,
    string idRayon,
    string rayon
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

titre String

[Missing <param name="titre"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

image String

[Missing <param name="image"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

duree Int32

[Missing <param name="duree"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

realisateur String

[Missing <param name="realisateur"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

synopsis String

[Missing <param name="synopsis"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idGenre String

[Missing <param name="idGenre"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

genre String

[Missing <param name="genre"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idPublic String

[Missing <param name="idPublic"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

lePublic String

[Missing <param name="lePublic"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idRayon String

[Missing <param name="idRayon"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

rayon String

[Missing <param name="rayon"/> documentation for "M:MediaTekDocuments.model.Dvd.#ctor(System.String,System.String,System.String,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

See Also

Reference

Dvd Class


Dvd Properties

The Dvd type exposes the following members.

Properties
 | Name | Description
Public property | Duree |
Public property | Genre | (Inherited from Document)
Public property | Id | (Inherited from Document)
Public property | IdGenre | (Inherited from Document)
Public property | IdPublic | (Inherited from Document)
Public property | IdRayon | (Inherited from Document)
Public property | Image | (Inherited from Document)
Public property | Public | (Inherited from Document)
Public property | Rayon | (Inherited from Document)
Public property | Realisateur |
Public property | Synopsis |
Public property | Titre | (Inherited from Document)
Top
See Also

Reference

Dvd Class


Dvd.Duree Property

A Sandcastle Documented Class Library

DvdDuree Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Dvd.Duree"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Duree { get; }

Property Value

Int32
See Also

Reference

Dvd Class


Dvd.Realisateur Property

A Sandcastle Documented Class Library

DvdRealisateur Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Dvd.Realisateur"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Realisateur { get; }

Property Value

String
See Also

Reference

Dvd Class


Dvd.Synopsis Property

A Sandcastle Documented Class Library

DvdSynopsis Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Dvd.Synopsis"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Synopsis { get; }

Property Value

String
See Also

Reference

Dvd Class


Dvd Methods

The Dvd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Dvd Class


Etat Class

Classe métier Etat (état d'usure d'un document)
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelEtat

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Etat

The Etat type exposes the following members.

Constructors
 | Name | Description
Public method | Etat | Initializes a new instance of the Etat class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Libelle |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Overrides ObjectToString)
Top
See Also

Reference


Etat Constructor

Initializes a new instance of the Etat class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Etat(
    string id,
    string libelle
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Etat.#ctor(System.String,System.String)"]

libelle String

[Missing <param name="libelle"/> documentation for "M:MediaTekDocuments.model.Etat.#ctor(System.String,System.String)"]

See Also

Reference

Etat Class


Etat Properties

The Etat type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Libelle |
Top
See Also

Reference

Etat Class


Etat.Id Property

A Sandcastle Documented Class Library

EtatId Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Etat.Id"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Id { get; }

Property Value

String
See Also

Reference

Etat Class


Etat.Libelle Property

A Sandcastle Documented Class Library

EtatLibelle Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Etat.Libelle"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Libelle { get; }

Property Value

String
See Also

Reference

Etat Class


Etat Methods

The Etat type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Overrides ObjectToString)
Top
See Also

Reference

Etat Class


Etat.ToString Method

A Sandcastle Documented Class Library

EtatToString Method

Récupération du libellé pour l'affichage dans les combos

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
Libelle
See Also

Reference

Etat Class


Exemplaire Class

Classe métier Exemplaire (exemplaire d'une revue)
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelExemplaire

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Exemplaire

The Exemplaire type exposes the following members.

Constructors
 | Name | Description
Public method | Exemplaire | Initializes a new instance of the Exemplaire class
Top
Properties
 | Name | Description
Public property | DateAchat |
Public property | Id |
Public property | IdEtat |
Public property | Numero |
Public property | Photo |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


Exemplaire Constructor

Initializes a new instance of the Exemplaire class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Exemplaire(
    int numero,
    DateTime dateAchat,
    string photo,
    string idEtat,
    string idDocument
)

Parameters

numero Int32

[Missing <param name="numero"/> documentation for "M:MediaTekDocuments.model.Exemplaire.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String)"]

dateAchat DateTime

[Missing <param name="dateAchat"/> documentation for "M:MediaTekDocuments.model.Exemplaire.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String)"]

photo String

[Missing <param name="photo"/> documentation for "M:MediaTekDocuments.model.Exemplaire.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String)"]

idEtat String

[Missing <param name="idEtat"/> documentation for "M:MediaTekDocuments.model.Exemplaire.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String)"]

idDocument String

[Missing <param name="idDocument"/> documentation for "M:MediaTekDocuments.model.Exemplaire.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String)"]

See Also

Reference

Exemplaire Class


Exemplaire Properties

The Exemplaire type exposes the following members.

Properties
 | Name | Description
Public property | DateAchat |
Public property | Id |
Public property | IdEtat |
Public property | Numero |
Public property | Photo |
Top
See Also

Reference

Exemplaire Class


Exemplaire.DateAchat Property

A Sandcastle Documented Class Library

ExemplaireDateAchat Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Exemplaire.DateAchat"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DateTime DateAchat { get; set; }

Property Value

DateTime
See Also

Reference

Exemplaire Class


Exemplaire.Id Property

A Sandcastle Documented Class Library

ExemplaireId Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Exemplaire.Id"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Id { get; set; }

Property Value

String
See Also

Reference

Exemplaire Class


Exemplaire.IdEtat Property

A Sandcastle Documented Class Library

ExemplaireIdEtat Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Exemplaire.IdEtat"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string IdEtat { get; set; }

Property Value

String
See Also

Reference

Exemplaire Class


Exemplaire.Numero Property

A Sandcastle Documented Class Library

ExemplaireNumero Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Exemplaire.Numero"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Numero { get; set; }

Property Value

Int32
See Also

Reference

Exemplaire Class


Exemplaire.Photo Property

A Sandcastle Documented Class Library

ExemplairePhoto Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Exemplaire.Photo"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Photo { get; set; }

Property Value

String
See Also

Reference

Exemplaire Class


Exemplaire Methods

The Exemplaire type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Exemplaire Class


Genre Class

Classe métier Genre : hérite de Categorie
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelCategorie
MediaTekDocuments.modelGenre

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Genre : Categorie

The Genre type exposes the following members.

Constructors
 | Name | Description
Public method | Genre | Initializes a new instance of the Genre class
Top
Properties
 | Name | Description
Public property | Id | (Inherited from Categorie)
Public property | Libelle | (Inherited from Categorie)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Inherited from Categorie)
Top
See Also

Reference


Genre Constructor

Initializes a new instance of the Genre class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Genre(
    string id,
    string libelle
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Genre.#ctor(System.String,System.String)"]

libelle String

[Missing <param name="libelle"/> documentation for "M:MediaTekDocuments.model.Genre.#ctor(System.String,System.String)"]

See Also

Reference

Genre Class


Genre Properties

The Genre type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from Categorie)
Public property | Libelle | (Inherited from Categorie)
Top
See Also

Reference

Genre Class


Genre Methods

The Genre type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Inherited from Categorie)
Top
See Also

Reference

Genre Class


Livre Class

Classe métier Livre hérite de LivreDvd : contient des propriétés spécifiques aux livres
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelDocument
MediaTekDocuments.modelLivreDvd
MediaTekDocuments.modelLivre

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Livre : LivreDvd

The Livre type exposes the following members.

Constructors
 | Name | Description
Public method | Livre | Initializes a new instance of the Livre class
Top
Properties
 | Name | Description
Public property | Auteur |
Public property | Collection |
Public property | Genre | (Inherited from Document)
Public property | Id | (Inherited from Document)
Public property | IdGenre | (Inherited from Document)
Public property | IdPublic | (Inherited from Document)
Public property | IdRayon | (Inherited from Document)
Public property | Image | (Inherited from Document)
Public property | Isbn |
Public property | Public | (Inherited from Document)
Public property | Rayon | (Inherited from Document)
Public property | Titre | (Inherited from Document)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


Livre Constructor

Initializes a new instance of the Livre class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Livre(
    string id,
    string titre,
    string image,
    string isbn,
    string auteur,
    string collection,
    string idGenre,
    string genre,
    string idPublic,
    string lePublic,
    string idRayon,
    string rayon
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

titre String

[Missing <param name="titre"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

image String

[Missing <param name="image"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

isbn String

[Missing <param name="isbn"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

auteur String

[Missing <param name="auteur"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

collection String

[Missing <param name="collection"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idGenre String

[Missing <param name="idGenre"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

genre String

[Missing <param name="genre"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idPublic String

[Missing <param name="idPublic"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

lePublic String

[Missing <param name="lePublic"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idRayon String

[Missing <param name="idRayon"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

rayon String

[Missing <param name="rayon"/> documentation for "M:MediaTekDocuments.model.Livre.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

See Also

Reference

Livre Class


Livre Properties

The Livre type exposes the following members.

Properties
 | Name | Description
Public property | Auteur |
Public property | Collection |
Public property | Genre | (Inherited from Document)
Public property | Id | (Inherited from Document)
Public property | IdGenre | (Inherited from Document)
Public property | IdPublic | (Inherited from Document)
Public property | IdRayon | (Inherited from Document)
Public property | Image | (Inherited from Document)
Public property | Isbn |
Public property | Public | (Inherited from Document)
Public property | Rayon | (Inherited from Document)
Public property | Titre | (Inherited from Document)
Top
See Also

Reference

Livre Class


Livre.Auteur Property

A Sandcastle Documented Class Library

LivreAuteur Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Livre.Auteur"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Auteur { get; }

Property Value

String
See Also

Reference

Livre Class


Livre.Collection Property

A Sandcastle Documented Class Library

LivreCollection Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Livre.Collection"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Collection { get; }

Property Value

String
See Also

Reference

Livre Class


Livre.Isbn Property

A Sandcastle Documented Class Library

LivreIsbn Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Livre.Isbn"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Isbn { get; }

Property Value

String
See Also

Reference

Livre Class


Livre Methods

The Livre type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Livre Class


LivreDvd Class

Classe métier LivreDvd hérite de Document
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelDocument
MediaTekDocuments.modelLivreDvd
MediaTekDocuments.modelDvd
MediaTekDocuments.modelLivre

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public abstract class LivreDvd : Document

The LivreDvd type exposes the following members.

Constructors
 | Name | Description
Protected method | LivreDvd | Initializes a new instance of the LivreDvd class
Top
Properties
 | Name | Description
Public property | Genre | (Inherited from Document)
Public property | Id | (Inherited from Document)
Public property | IdGenre | (Inherited from Document)
Public property | IdPublic | (Inherited from Document)
Public property | IdRayon | (Inherited from Document)
Public property | Image | (Inherited from Document)
Public property | Public | (Inherited from Document)
Public property | Rayon | (Inherited from Document)
Public property | Titre | (Inherited from Document)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


LivreDvd Constructor

Initializes a new instance of the LivreDvd class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected LivreDvd(
    string id,
    string titre,
    string image,
    string idGenre,
    string genre,
    string idPublic,
    string lePublic,
    string idRayon,
    string rayon
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

titre String

[Missing <param name="titre"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

image String

[Missing <param name="image"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idGenre String

[Missing <param name="idGenre"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

genre String

[Missing <param name="genre"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idPublic String

[Missing <param name="idPublic"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

lePublic String

[Missing <param name="lePublic"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

idRayon String

[Missing <param name="idRayon"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

rayon String

[Missing <param name="rayon"/> documentation for "M:MediaTekDocuments.model.LivreDvd.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

See Also

Reference

LivreDvd Class


LivreDvd Properties

The LivreDvd type exposes the following members.

Properties
 | Name | Description
Public property | Genre | (Inherited from Document)
Public property | Id | (Inherited from Document)
Public property | IdGenre | (Inherited from Document)
Public property | IdPublic | (Inherited from Document)
Public property | IdRayon | (Inherited from Document)
Public property | Image | (Inherited from Document)
Public property | Public | (Inherited from Document)
Public property | Rayon | (Inherited from Document)
Public property | Titre | (Inherited from Document)
Top
See Also

Reference

LivreDvd Class


LivreDvd Methods

The LivreDvd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LivreDvd Class


Public Class

Classe métier Public (public concerné par le document) hérite de Categorie
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelCategorie
MediaTekDocuments.modelPublic

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Public : Categorie

The Public type exposes the following members.

Constructors
 | Name | Description
Public method | Public | Initializes a new instance of the Public class
Top
Properties
 | Name | Description
Public property | Id | (Inherited from Categorie)
Public property | Libelle | (Inherited from Categorie)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Inherited from Categorie)
Top
See Also

Reference


Public Constructor

Initializes a new instance of the Public class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Public(
    string id,
    string libelle
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Public.#ctor(System.String,System.String)"]

libelle String

[Missing <param name="libelle"/> documentation for "M:MediaTekDocuments.model.Public.#ctor(System.String,System.String)"]

See Also

Reference

Public Class


Public Properties

The Public type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from Categorie)
Public property | Libelle | (Inherited from Categorie)
Top
See Also

Reference

Public Class


Public Methods

The Public type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Inherited from Categorie)
Top
See Also

Reference

Public Class


Rayon Class

Classe métier Rayon (rayon de classement du document) hérite de Categorie
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelCategorie
MediaTekDocuments.modelRayon

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Rayon : Categorie

The Rayon type exposes the following members.

Constructors
 | Name | Description
Public method | Rayon | Initializes a new instance of the Rayon class
Top
Properties
 | Name | Description
Public property | Id | (Inherited from Categorie)
Public property | Libelle | (Inherited from Categorie)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Inherited from Categorie)
Top
See Also

Reference


Rayon Constructor

Initializes a new instance of the Rayon class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Rayon(
    string id,
    string libelle
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Rayon.#ctor(System.String,System.String)"]

libelle String

[Missing <param name="libelle"/> documentation for "M:MediaTekDocuments.model.Rayon.#ctor(System.String,System.String)"]

See Also

Reference

Rayon Class


Rayon Properties

The Rayon type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from Categorie)
Public property | Libelle | (Inherited from Categorie)
Top
See Also

Reference

Rayon Class


Rayon Methods

The Rayon type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Inherited from Categorie)
Top
See Also

Reference

Rayon Class


Revue Class

Classe métier Revue hérite de Document : contient des propriétés spécifiques aux revues
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelDocument
MediaTekDocuments.modelRevue

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Revue : Document

The Revue type exposes the following members.

Constructors
 | Name | Description
Public method | Revue | Initializes a new instance of the Revue class
Top
Properties
 | Name | Description
Public property | DelaiMiseADispo |
Public property | Genre | (Inherited from Document)
Public property | Id | (Inherited from Document)
Public property | IdGenre | (Inherited from Document)
Public property | IdPublic | (Inherited from Document)
Public property | IdRayon | (Inherited from Document)
Public property | Image | (Inherited from Document)
Public property | Periodicite |
Public property | Public | (Inherited from Document)
Public property | Rayon | (Inherited from Document)
Public property | Titre | (Inherited from Document)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


Revue Constructor

Initializes a new instance of the Revue class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Revue(
    string id,
    string titre,
    string image,
    string idGenre,
    string genre,
    string idPublic,
    string lePublic,
    string idRayon,
    string rayon,
    string periodicite,
    int delaiMiseADispo
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

titre String

[Missing <param name="titre"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

image String

[Missing <param name="image"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

idGenre String

[Missing <param name="idGenre"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

genre String

[Missing <param name="genre"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

idPublic String

[Missing <param name="idPublic"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

lePublic String

[Missing <param name="lePublic"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

idRayon String

[Missing <param name="idRayon"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

rayon String

[Missing <param name="rayon"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

periodicite String

[Missing <param name="periodicite"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

delaiMiseADispo Int32

[Missing <param name="delaiMiseADispo"/> documentation for "M:MediaTekDocuments.model.Revue.#ctor(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Int32)"]

See Also

Reference

Revue Class


Revue Properties

The Revue type exposes the following members.

Properties
 | Name | Description
Public property | DelaiMiseADispo |
Public property | Genre | (Inherited from Document)
Public property | Id | (Inherited from Document)
Public property | IdGenre | (Inherited from Document)
Public property | IdPublic | (Inherited from Document)
Public property | IdRayon | (Inherited from Document)
Public property | Image | (Inherited from Document)
Public property | Periodicite |
Public property | Public | (Inherited from Document)
Public property | Rayon | (Inherited from Document)
Public property | Titre | (Inherited from Document)
Top
See Also

Reference

Revue Class


Revue.DelaiMiseADispo Property

A Sandcastle Documented Class Library

RevueDelaiMiseADispo Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Revue.DelaiMiseADispo"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int DelaiMiseADispo { get; set; }

Property Value

Int32
See Also

Reference

Revue Class


Revue.Periodicite Property

A Sandcastle Documented Class Library

RevuePeriodicite Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Revue.Periodicite"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Periodicite { get; set; }

Property Value

String
See Also

Reference

Revue Class


Revue Methods

The Revue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Revue Class


Service Class

Classe métier liée à la table Service
Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelService

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Service

The Service type exposes the following members.

Constructors
 | Name | Description
Public method | Service | Valorise les propriétés
Top
Properties
 | Name | Description
Public property | Id |
Public property | Libelle |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Définit l'information à afficher (juste le nom) (Overrides ObjectToString)
Top
See Also

Reference


Service Constructor

Valorise les propriétés

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Service(
    string id,
    string libelle
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Service.#ctor(System.String,System.String)"]

libelle String

[Missing <param name="libelle"/> documentation for "M:MediaTekDocuments.model.Service.#ctor(System.String,System.String)"]

See Also

Reference

Service Class


Service Properties

The Service type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Libelle |
Top
See Also

Reference

Service Class


Service.Id Property

A Sandcastle Documented Class Library

ServiceId Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Service.Id"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Id { get; }

Property Value

String
See Also

Reference

Service Class


Service.Libelle Property

A Sandcastle Documented Class Library

ServiceLibelle Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Service.Libelle"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Libelle { get; }

Property Value

String
See Also

Reference

Service Class


Service Methods

The Service type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Définit l'information à afficher (juste le nom) (Overrides ObjectToString)
Top
See Also

Reference

Service Class


Service.ToString Method

A Sandcastle Documented Class Library

ServiceToString Method

Définit l'information à afficher (juste le nom)

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
Nom du service
See Also

Reference

Service Class


Suivi Class

[Missing <summary> documentation for "T:MediaTekDocuments.model.Suivi"]

Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelSuivi

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Suivi

The Suivi type exposes the following members.

Constructors
 | Name | Description
Public method | Suivi | Initializes a new instance of the Suivi class
Top
Properties
 | Name | Description
Public property | Etat |
Public property | Id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Overrides ObjectToString)
Top
See Also

Reference


Suivi Constructor

Initializes a new instance of the Suivi class

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Suivi(
    int id,
    string etat
)

Parameters

id Int32

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Suivi.#ctor(System.Int32,System.String)"]

etat String

[Missing <param name="etat"/> documentation for "M:MediaTekDocuments.model.Suivi.#ctor(System.Int32,System.String)"]

See Also

Reference

Suivi Class


Suivi Properties

The Suivi type exposes the following members.

Properties
 | Name | Description
Public property | Etat |
Public property | Id |
Top
See Also

Reference

Suivi Class


Suivi.Etat Property

A Sandcastle Documented Class Library

SuiviEtat Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Suivi.Etat"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Etat { get; }

Property Value

String
See Also

Reference

Suivi Class


Suivi.Id Property

A Sandcastle Documented Class Library

SuiviId Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Suivi.Id"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

Suivi Class


Suivi Methods

The Suivi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Récupération du libellé pour l'affichage dans les combos (Overrides ObjectToString)
Top
See Also

Reference

Suivi Class


Suivi.ToString Method

A Sandcastle Documented Class Library

SuiviToString Method

Récupération du libellé pour l'affichage dans les combos

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
Libelle
See Also

Reference

Suivi Class


Utilisateur Class

[Missing <summary> documentation for "T:MediaTekDocuments.model.Utilisateur"]

Inheritance Hierarchy
SystemObject
MediaTekDocuments.modelUtilisateur

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Utilisateur

The Utilisateur type exposes the following members.

Constructors
 | Name | Description
Public method | Utilisateur | D Valorise les propriétés
Top
Properties
 | Name | Description
Public property | Id |
Public property | Mail |
Public property | Nom |
Public property | Prenom |
Public property | Service |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference


Utilisateur Constructor

D Valorise les propriétés

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Utilisateur(
    string id,
    string nom,
    string prenom,
    string mail,
    string idService,
    string service
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:MediaTekDocuments.model.Utilisateur.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

nom String

[Missing <param name="nom"/> documentation for "M:MediaTekDocuments.model.Utilisateur.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

prenom String

[Missing <param name="prenom"/> documentation for "M:MediaTekDocuments.model.Utilisateur.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

mail String

[Missing <param name="mail"/> documentation for "M:MediaTekDocuments.model.Utilisateur.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

idService String

[Missing <param name="idService"/> documentation for "M:MediaTekDocuments.model.Utilisateur.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

service String

[Missing <param name="service"/> documentation for "M:MediaTekDocuments.model.Utilisateur.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

See Also

Reference

Utilisateur Class


Utilisateur Properties

The Utilisateur type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Mail |
Public property | Nom |
Public property | Prenom |
Public property | Service |
Top
See Also

Reference

Utilisateur Class


Utilisateur.Id Property

A Sandcastle Documented Class Library

UtilisateurId Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Utilisateur.Id"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Id { get; }

Property Value

String
See Also

Reference

Utilisateur Class


Utilisateur.Mail Property

A Sandcastle Documented Class Library

UtilisateurMail Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Utilisateur.Mail"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Mail { get; set; }

Property Value

String
See Also

Reference

Utilisateur Class


Utilisateur.Nom Property

A Sandcastle Documented Class Library

UtilisateurNom Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Utilisateur.Nom"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Nom { get; set; }

Property Value

String
See Also

Reference

Utilisateur Class


Utilisateur.Prenom Property

A Sandcastle Documented Class Library

UtilisateurPrenom Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Utilisateur.Prenom"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Prenom { get; set; }

Property Value

String
See Also

Reference

Utilisateur Class


Utilisateur.Service Property

A Sandcastle Documented Class Library

UtilisateurService Property

[Missing <summary> documentation for "P:MediaTekDocuments.model.Utilisateur.Service"]

Namespace: MediaTekDocuments.model
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Service Service { get; }

Property Value

Service
See Also

Reference

Utilisateur Class


Utilisateur Methods

The Utilisateur type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Utilisateur Class


MediaTekDocuments.view Namespace

[Missing <summary> documentation for "N:MediaTekDocuments.view"]

Classes
 | Class | Description
Public class | FrmLogin |
Public class | FrmMediatek | Classe d'affichage


FrmLogin Class

[Missing <summary> documentation for "T:MediaTekDocuments.view.FrmLogin"]

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
MediaTekDocuments.viewFrmLogin

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class FrmLogin : Form

The FrmLogin type exposes the following members.

Constructors
 | Name | Description
Public method | FrmLogin | Initializes a new instance of the FrmLogin class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control)
Public property | Height | Gets or sets the height of the control. (Inherited from Control)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form)
Public property | Name | Gets or sets the name of the control. (Inherited from Control)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form)
Public property | Site | Gets or sets the site of the control. (Inherited from Control)
Public property | Size | Gets or sets the size of the form. (Inherited from Form)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Public property | Width | Gets or sets the width of the control. (Inherited from Control)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form)
Public method | Close | Closes the form. (Inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean))
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control)
Public method | Focus | Sets input focus to the control. (Inherited from Control)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Hide | Conceals the control from the user. (Inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control)
Protected method | OnClick | Raises the Click event. (Inherited from Control)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control)
Protected method | OnLoad | Raises the Load event. (Inherited from Form)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl)
Protected method | OnMove | Raises the Move event. (Inherited from Control)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control)
Protected method | OnResize | Raises the Resize event. (Inherited from Form)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl)
Protected method | OnShown | Raises the Shown event. (Inherited from Form)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control)
Public method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from Control)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl)
Public method | Select | Activates the control. (Inherited from Control)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form)
Public method | SelectNextControl | Activates the next control. (Inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form)
Public method | Show | Displays the control to the user. (Inherited from Control)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form)
Protected method | WndProc | Processes Windows messages. (Inherited from Form)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control)
Public event | Click | Occurs when the control is clicked. (Inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control)
Public event | Enter | Occurs when the control is entered. (Inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control)
Public event | Move | Occurs when the control is moved. (Inherited from Control)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control)
Public event | Resize | Occurs when the control is resized. (Inherited from Control)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control)
Public event | Validating | Occurs when the control is validating. (Inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control)
Top
See Also

Reference

MediaTekDocuments.view Namespace


FrmLogin Constructor

Initializes a new instance of the FrmLogin class

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public FrmLogin()
See Also

Reference

FrmLogin Class
MediaTekDocuments.view Namespace


FrmLogin Properties

The FrmLogin type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control)
Public property | Height | Gets or sets the height of the control. (Inherited from Control)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form)
Public property | Name | Gets or sets the name of the control. (Inherited from Control)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form)
Public property | Site | Gets or sets the site of the control. (Inherited from Control)
Public property | Size | Gets or sets the size of the form. (Inherited from Form)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Public property | Width | Gets or sets the width of the control. (Inherited from Control)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form)
Top
See Also

Reference

FrmLogin Class
MediaTekDocuments.view Namespace


FrmLogin Methods

The FrmLogin type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form)
Public method | Close | Closes the form. (Inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean))
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control)
Public method | Focus | Sets input focus to the control. (Inherited from Control)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Hide | Conceals the control from the user. (Inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control)
Protected method | OnClick | Raises the Click event. (Inherited from Control)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control)
Protected method | OnLoad | Raises the Load event. (Inherited from Form)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl)
Protected method | OnMove | Raises the Move event. (Inherited from Control)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control)
Protected method | OnResize | Raises the Resize event. (Inherited from Form)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl)
Protected method | OnShown | Raises the Shown event. (Inherited from Form)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control)
Public method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from Control)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl)
Public method | Select | Activates the control. (Inherited from Control)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form)
Public method | SelectNextControl | Activates the next control. (Inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form)
Public method | Show | Displays the control to the user. (Inherited from Control)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form)
Protected method | WndProc | Processes Windows messages. (Inherited from Form)
Top
See Also

Reference

FrmLogin Class
MediaTekDocuments.view Namespace


FrmLogin.Dispose Method

A Sandcastle Documented Class Library

FrmLoginDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component.
Protected method | Dispose(Boolean) | Clean up any resources being used.
Top
See Also

Reference

FrmLogin Class
MediaTekDocuments.view Namespace


FrmLogin.Dispose(Boolean) Method

A Sandcastle Documented Class Library

FrmLoginDispose(Boolean) Method

Clean up any resources being used.

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected override void Dispose(
    bool disposing
)

Parameters

disposing Boolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

FrmLogin Class
Dispose Overload
MediaTekDocuments.view Namespace


FrmLogin Events

The FrmLogin type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control)
Public event | Click | Occurs when the control is clicked. (Inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control)
Public event | Enter | Occurs when the control is entered. (Inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control)
Public event | Move | Occurs when the control is moved. (Inherited from Control)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control)
Public event | Resize | Occurs when the control is resized. (Inherited from Control)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control)
Public event | Validating | Occurs when the control is validating. (Inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control)
Top
See Also

Reference

FrmLogin Class
MediaTekDocuments.view Namespace


FrmMediatek Class

Classe d'affichage
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
MediaTekDocuments.viewFrmMediatek

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class FrmMediatek : Form

The FrmMediatek type exposes the following members.

Constructors
 | Name | Description
Public method | FrmMediatek | Constructeur : création du contrôleur lié à ce formulaire
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control)
Public property | Height | Gets or sets the height of the control. (Inherited from Control)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form)
Public property | Name | Gets or sets the name of the control. (Inherited from Control)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form)
Public property | Site | Gets or sets the site of the control. (Inherited from Control)
Public property | Size | Gets or sets the size of the form. (Inherited from Form)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Public property | Width | Gets or sets the width of the control. (Inherited from Control)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form)
Public method | Close | Closes the form. (Inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées. (Overrides FormDispose(Boolean))
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control)
Public method | DvdComValide | Demande au contrôleur de faire la modification/l'ajout
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control)
Public method | Focus | Sets input focus to the control. (Inherited from Control)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Hide | Conceals the control from the user. (Inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control)
Protected method | OnClick | Raises the Click event. (Inherited from Control)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control)
Protected method | OnLoad | Raises the Load event. (Inherited from Form)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl)
Protected method | OnMove | Raises the Move event. (Inherited from Control)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control)
Protected method | OnResize | Raises the Resize event. (Inherited from Form)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl)
Protected method | OnShown | Raises the Shown event. (Inherited from Form)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form)
Public method | RemplirComboCategorie | Rempli un des 3 combo (genre, public, rayon)
Public method | RemplirComboEtat | Rempli un combo d'etat
Public method | RemplirComboSuivi | Rempli un combo de suivi
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control)
Public method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from Control)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl)
Public method | Select | Activates the control. (Inherited from Control)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form)
Public method | SelectNextControl | Activates the next control. (Inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form)
Public method | Show | Displays the control to the user. (Inherited from Control)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form)
Protected method | WndProc | Processes Windows messages. (Inherited from Form)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control)
Public event | Click | Occurs when the control is clicked. (Inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control)
Public event | Enter | Occurs when the control is entered. (Inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control)
Public event | Move | Occurs when the control is moved. (Inherited from Control)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control)
Public event | Resize | Occurs when the control is resized. (Inherited from Control)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control)
Public event | Validating | Occurs when the control is validating. (Inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control)
Top
Fields
 | Name | Description
Protected field | label61 |
Top
See Also

Reference

MediaTekDocuments.view Namespace


FrmMediatek Constructor

Constructeur : création du contrôleur lié à ce formulaire

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public FrmMediatek(
    Utilisateur lutilisateur
)

Parameters

lutilisateur Utilisateur

[Missing <param name="lutilisateur"/> documentation for "M:MediaTekDocuments.view.FrmMediatek.#ctor(MediaTekDocuments.model.Utilisateur)"]

See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek Properties

The FrmMediatek type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control)
Public property | Height | Gets or sets the height of the control. (Inherited from Control)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form)
Public property | Name | Gets or sets the name of the control. (Inherited from Control)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form)
Public property | Site | Gets or sets the site of the control. (Inherited from Control)
Public property | Size | Gets or sets the size of the form. (Inherited from Form)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Public property | Width | Gets or sets the width of the control. (Inherited from Control)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form)
Top
See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek Methods

The FrmMediatek type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form)
Public method | Close | Closes the form. (Inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées. (Overrides FormDispose(Boolean))
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control)
Public method | DvdComValide | Demande au contrôleur de faire la modification/l'ajout
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control)
Public method | Focus | Sets input focus to the control. (Inherited from Control)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Hide | Conceals the control from the user. (Inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control)
Protected method | OnClick | Raises the Click event. (Inherited from Control)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control)
Protected method | OnLoad | Raises the Load event. (Inherited from Form)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl)
Protected method | OnMove | Raises the Move event. (Inherited from Control)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control)
Protected method | OnResize | Raises the Resize event. (Inherited from Form)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl)
Protected method | OnShown | Raises the Shown event. (Inherited from Form)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form)
Public method | RemplirComboCategorie | Rempli un des 3 combo (genre, public, rayon)
Public method | RemplirComboEtat | Rempli un combo d'etat
Public method | RemplirComboSuivi | Rempli un combo de suivi
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control)
Public method | Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from Control)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl)
Public method | Select | Activates the control. (Inherited from Control)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form)
Public method | SelectNextControl | Activates the next control. (Inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form)
Public method | Show | Displays the control to the user. (Inherited from Control)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form)
Protected method | WndProc | Processes Windows messages. (Inherited from Form)
Top
See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek.Dispose Method

A Sandcastle Documented Class Library

FrmMediatekDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component.
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Top
See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek.Dispose(Boolean) Method

A Sandcastle Documented Class Library

FrmMediatekDispose(Boolean) Method

Nettoyage des ressources utilisées.

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected override void Dispose(
    bool disposing
)

Parameters

disposing Boolean
true si les ressources managées doivent être supprimées ; sinon, false.
See Also

Reference

FrmMediatek Class
Dispose Overload
MediaTekDocuments.view Namespace


FrmMediatek.DvdComValide Method

A Sandcastle Documented Class Library

FrmMediatekDvdComValide Method

Demande au contrôleur de faire la modification/l'ajout

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void DvdComValide(
    CommandeDocument commandeLivre
)

Parameters

commandeLivre CommandeDocument

[Missing <param name="commandeLivre"/> documentation for "M:MediaTekDocuments.view.FrmMediatek.DvdComValide(MediaTekDocuments.model.CommandeDocument)"]

See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek.RemplirComboCategorie Method

A Sandcastle Documented Class Library

FrmMediatekRemplirComboCategorie Method

Rempli un des 3 combo (genre, public, rayon)

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void RemplirComboCategorie(
    List<Categorie> lesCategories,
    BindingSource bdg,
    ComboBox cbx
)

Parameters

lesCategories List Categorie
liste des objets de type Genre ou Public ou Rayon
bdg BindingSource
bindingsource contenant les informations
cbx ComboBox
combobox à remplir
See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek.RemplirComboEtat Method

A Sandcastle Documented Class Library

FrmMediatekRemplirComboEtat Method

Rempli un combo d'etat

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void RemplirComboEtat(
    List<Etat> lesEtats,
    BindingSource bdg,
    ComboBox cbx
)

Parameters

lesEtats List Etat

[Missing <param name="lesEtats"/> documentation for "M:MediaTekDocuments.view.FrmMediatek.RemplirComboEtat(System.Collections.Generic.List{MediaTekDocuments.model.Etat},System.Windows.Forms.BindingSource,System.Windows.Forms.ComboBox)"]

bdg BindingSource

[Missing <param name="bdg"/> documentation for "M:MediaTekDocuments.view.FrmMediatek.RemplirComboEtat(System.Collections.Generic.List{MediaTekDocuments.model.Etat},System.Windows.Forms.BindingSource,System.Windows.Forms.ComboBox)"]

cbx ComboBox

[Missing <param name="cbx"/> documentation for "M:MediaTekDocuments.view.FrmMediatek.RemplirComboEtat(System.Collections.Generic.List{MediaTekDocuments.model.Etat},System.Windows.Forms.BindingSource,System.Windows.Forms.ComboBox)"]

See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek.RemplirComboSuivi Method

A Sandcastle Documented Class Library

FrmMediatekRemplirComboSuivi Method

Rempli un combo de suivi

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void RemplirComboSuivi(
    List<Suivi> lesSuivis,
    BindingSource bdg,
    ComboBox cbx
)

Parameters

lesSuivis List Suivi

[Missing <param name="lesSuivis"/> documentation for "M:MediaTekDocuments.view.FrmMediatek.RemplirComboSuivi(System.Collections.Generic.List{MediaTekDocuments.model.Suivi},System.Windows.Forms.BindingSource,System.Windows.Forms.ComboBox)"]

bdg BindingSource
bindingsource contenant les informations
cbx ComboBox
combobox à remplir
See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek Events

The FrmMediatek type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control)
Public event | Click | Occurs when the control is clicked. (Inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control)
Public event | Enter | Occurs when the control is entered. (Inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control)
Public event | Move | Occurs when the control is moved. (Inherited from Control)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control)
Public event | Resize | Occurs when the control is resized. (Inherited from Control)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control)
Public event | Validating | Occurs when the control is validating. (Inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control)
Top
See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek Fields

The FrmMediatek type exposes the following members.

Fields
 | Name | Description
Protected field | label61 |
Top
See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace


FrmMediatek.label61 Field

A Sandcastle Documented Class Library

FrmMediateklabel61 Field

[Missing <summary> documentation for "F:MediaTekDocuments.view.FrmMediatek.label61"]

Namespace: MediaTekDocuments.view
Assembly: MediaTekDocuments (in MediaTekDocuments.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected Label label61

Field Value

Label
See Also

Reference

FrmMediatek Class
MediaTekDocuments.view Namespace